Настройка маршрутизаторов MikroTik

Для просмотра IPTV в маршрутизаторах MikroTik необходимо:

1). Скачать текущую (Current) прошивку с сайта MikroTik (Main package и Extra packages), как правило прошивка нужна mipsbe (для роутеров RB7xx series, RB9xx series, RB2011 series). Распаковать архив all_packages-mipsbe-x.x.x.zip, оттуда понадобится пакет multicast-x.x.x-mipsbe.npk. Зайти на роутер, в меню files скопировать файлы routeros-mipsbe-x.x.x.npk и multicast-x.x.x-mipsbe.npk. После этого перезагрузить роутер (команда /system reboot) и НЕ выключать питание, через пару минут он загрузится сам. После перезагрузки на роутере будет установлена новая прошивка и пакет multicast.

2). Из консоли (New terminal) ввести следующее (ВНИМАНИЕ: данный сценарий частично удалит и заново создаст правила /ip firewall и /routing igmp-proxy):

/ip firewall filter remove [/ip firewall filter find chain="input" action="accept" in-interface="ether1" protocol="igmp"];
/ip firewall filter add chain=input action=accept in-interface=ether1 protocol=igmp place-before 1;
/ip firewall filter remove [/ip firewall filter find chain="input" action="accept" in-interface="ether1" protocol="udp" src-address="0.0.0.0/0" dst-port="1234"];
/ip firewall filter add chain=input action=accept in-interface=ether1 protocol=udp src-address=0.0.0.0/0 dst-port=1234 place-before 2;
/ip firewall filter remove [/ip firewall filter find chain="forward" action="accept" in-interface="ether1" protocol="udp" src-address="0.0.0.0/0" dst-port="1234"];
/ip firewall filter add chain=forward action=accept in-interface=ether1 protocol=udp src-address=0.0.0.0/0 dst-port=1234 place-before 3;
/routing igmp-proxy interface remove [/routing igmp-proxy interface find];
/routing igmp-proxy interface add alternative-subnets=0.0.0.0/0 interface=ether1 threshold=1 upstream=yes;
/routing igmp-proxy interface add interface=bridge threshold=1 upstream=no;
/interface bridge set [/interface bridge find] igmp-snooping=yes;

После последней команды не забыть нажать ENTER. Правила сработают если у вас стандартные названия интерфейсов ether1 (для WAN) и bridge (для LAN).

PS. Инструкция применима к роутерам с конфигурацией по-умолчанию. Если роутер без WiFi и не имеет интерфейса bridge-local, то в командах нужно заменить bridge-local на ether2-master-local.

Последние изменения: 16:31 17.03.2018 — andre
© 2010 - 2018 "Псковлайн.ТВ"
Телевидение высокой четкости.
многоканальный телефон
(8112) 70-00-00